Access Denied Errors

Problem

While provisioning an account on a cPanel & WHM or WP Squared server, you see the following error:

Access Denied/Permission Denied

Cause

An Access Denied error indicates that the server denied WHMCS access to perform the requested action (for example, creating an account).

Solution

To resolve this issue:

  1. Go to Configuration () > System Settings > Servers.
  2. Check whether the server settings, including the username and API token, are valid.
  3. Check whether the API credentials for the server have the required permissions to perform the action.
  4. Click Test Connection to confirm that the account has access.

If the issue persists, check the Module Log at Configuration () > System Logs.

Last modified: 2025 June 11